Network Address Translation

Network Address Translation or NAT is a brilliant scheme to preserve IP addresses. Organizations are often assigned a limited number of public IP addresses. It would be extremely expensive to convert all private IP addresses to public addresses for outside communication. NAT offers a brilliant solution to this problem. NAT allows 3 different ways of mapping internal IP addresses to public IP addresses.

Before we dive into the different types of NATs lets first clarify the terminologies that are often confusing.

The IP address of the private network host is called inside local and once that private IP address is mapped to a public IP address it becomes inside global. For e.g in the above fig we can see that the IP address of the inside host changes for 10.10.10.1 to 72.16.92.10. The IP address 10.10.10.1 is refereed as Inside Local and the IP address after mapping 72.16.92.10 is refereed as Inside Global

And similarly, a public IP address is called outside global and when it is mapped to a private IP address it is called outside local. For e.g in the above fig we can see that the IP address of the Public host changes for 72.16.92.9 to 10.10.10.10. The IP address 72.16.92.9 is refereed as Outside Global and the IP address after mapping 10.10.10.10 is refereed as Outside Local

Now, the 3 types of NATs are

  • Static NAT
  • Dynamic NAT
  • Port Address Translation

The following lab is an example of all three nats

 Router#sh run
 Building configuration…
 Current configuration : 3655 bytes
 !
 ! Last configuration change at 20:23:44 UTC Mon Dec 16 2019
 !
 version 15.6
 service timestamps debug datetime msec
 service timestamps log datetime msec
 no service password-encryption
 !
 hostname Router
 !
 boot-start-marker
 boot-end-marker
 !
 no aaa new-model
 ethernet lmi ce
 !
 no process cpu autoprofile hog
 mmi polling-interval 60
 no mmi auto-configure
 no mmi pvc
 mmi snmp-timeout 180
 !
 ip icmp rate-limit unreachable
 !
 no ip domain lookup
 ip cef
 no ipv6 cef
 !
 multilink bundle-name authenticated
 !
 redundancy
 !
 no cdp log mismatch duplex
 no cdp run
 !
 ip tcp synwait-time 5
 !
 interface GigabitEthernet0/0
  ip address 172.16.0.1 255.255.255.0
  ip nat outside
  ip virtual-reassembly in
  duplex auto
  speed auto
  media-type rj45
  no cdp enable
 !
 interface GigabitEthernet0/1
  description Static NAT
  ip address 10.10.10.1 255.255.255.252
  ip nat inside
  ip virtual-reassembly in
  duplex auto
  speed auto
  media-type rj45
  no cdp enable
 !
 interface GigabitEthernet0/2
  description Dynamic NAT
  ip address 10.20.20.1 255.255.255.252
  duplex auto
  speed auto
  media-type rj45
  no cdp enable
 !
 interface GigabitEthernet0/3
  description PAT
  ip address 192.168.0.1 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  no cdp enable
 !
 ip forward-protocol nd
 !
 !
 no ip http server
 no ip http secure-server
 ip nat pool dynamicNAT 172.16.0.30 172.16.0.40 netmask 255.255.255.0
 ip nat inside source list 7 pool dynamicNAT
 !to perform PAT we would do  ip nat inside source list 7 pool dynamicNAT overload
 ip nat inside source static 10.10.10.2 172.16.0.2
 !
 !
 !
 access-list 7 permit 10.20.20.0 0.0.0.255
 end 

Comments

  1. Kathryn Marsh

    I’m not sure where you are getting your information, but good topic. I needs to spend some time learning much more or understanding more. Thanks for wonderful info I was looking for this info for my mission.

  2. g

    I’m not that much of a online reader to be honest but your blogs really nice,
    keep it up! I’ll go ahead and bookmark your site to come back later.
    All the best

  3. so g

    Greetings I am so thrilled I found your blog, I really found you by error, while I was
    searching on Aol for something else, Regardless I
    am here now and would just like to say thank you for a fantastic post and a all round enjoyable blog (I also love the theme/design),
    I don’t have time to go through it all at the minute
    but I have book-marked it and also included your RSS feeds, so when I have time I
    will be back to read more, Please do keep up the awesome work.

  4. g or

    I think this is among the most important info for me.

    And i am glad reading your article. But should remark on few general things,
    The site style is great, the articles is really great : D.
    Good job, cheers

  5. g into

    Hello there! Quick question that’s totally off topic.
    Do you know how to make your site mobile friendly?
    My web site looks weird when browsing from my iphone4.
    I’m trying to find a template or plugin that might be
    able to fix this problem. If you have any recommendations, please share.
    With thanks!

  6. its g

    Hey there! I’ve been reading your blog for a long time now and finally got the courage to
    go ahead and give you a shout out from Huffman Texas!
    Just wanted to tell you keep up the excellent work!

  7. the g

    Today, while I was at work, my sister stole my apple ipad and tested to see if it can survive a 25 foot drop, just so she can be a youtube sensation.
    My apple ipad is now destroyed and she has 83 views.
    I know this is completely off topic but I had to share it with someone!

  8. if g

    What’s up to all, the contents present at this site are really awesome for
    people knowledge, well, keep up the good work
    fellows.

  9. kinodron.net

    hello!,I love your writing very a lot! percentage we communicate
    more approximately your post on AOL? I require a specialist in this house to unravel my problem.
    Maybe that is you! Looking ahead to see you.

  10. tinyurl.com

    Terrific article! This is the kind of information that are
    meant to be shared across the web. Shame on Google for no longer positioning this publish higher!
    Come on over and talk over with my site . Thanks =)

  11. cbd oil that works 2020

    I really love your blog.. Excellent colors &
    theme. Did you make this website yourself? Please reply back as I’m trying to create
    my very own site and would love to find out where you got this from or what the
    theme is called. Thanks!

  12. content hosting

    Usually I don’t read post on blogs, however I would like to say that this write-up very forced
    me to try and do it! Your writing taste has been surprised me.
    Thank you, quite nice post.

  13. best web hosting company

    Fantastic beat ! I would like to apprentice while you amend your web site,
    how could i subscribe for a blog website?
    The account helped me a acceptable deal. I had been a
    little bit acquainted of this your broadcast offered bright clear idea

  14. best hosting

    Thanks for ones marvelous posting! I certainly
    enjoyed reading it, you are a great author.I will remember to bookmark your blog and
    may come back in the foreseeable future. I want to encourage yourself to continue
    your great job, have a nice morning!

  15. cheap flights tickets

    Hey! I know this is somewhat off topic but I was wondering if you knew
    where I could get a captcha plugin for my comment form?
    I’m using the same blog platform as yours and I’m having trouble finding one?

    Thanks a lot!

  16. webhosting

    With havin so much content and articles do
    you ever run into any problems of plagorism or copyright violation? My website has a lot of exclusive content I’ve either created myself or outsourced but
    it looks like a lot of it is popping it up all over
    the web without my agreement. Do you know any methods to help prevent content from being ripped off?
    I’d definitely appreciate it.

  17. best web hosting

    Howdy I am so grateful I found your web site, I really
    found you by error, while I was browsing on Yahoo for
    something else, Anyways I am here now and would just like to say cheers for a tremendous post and a all round entertaining blog (I also love the theme/design), I don’t have
    time to read it all at the moment but I have saved it and also added your RSS feeds, so when I have time I will be back to read
    much more, Please do keep up the excellent job.

  18. web hosting companies

    Greetings! This is my first visit to your blog! We are a collection of volunteers and starting a new initiative in a community in the same niche.
    Your blog provided us useful information to work on.
    You have done a wonderful job!

  19. website hosting companies

    Hi! I understand this is kind of off-topic however I had to ask.
    Does building a well-established blog like yours require a
    large amount of work? I am brand new to blogging however I do write
    in my diary every day. I’d like to start a blog
    so I can share my own experience and views online.
    Please let me know if you have any suggestions or tips for brand new aspiring bloggers.
    Thankyou!

  20. hosting services

    Hmm it looks like your blog ate my first
    comment (it was extremely long) so I guess I’ll just sum it up what I wrote and say,
    I’m thoroughly enjoying your blog. I too am an aspiring blog blogger but I’m still new to the whole
    thing. Do you have any helpful hints for inexperienced blog writers?
    I’d definitely appreciate it.

  21. website hosting companies

    You actually make it appear so easy along with your presentation however I to find this matter to be
    actually one thing that I feel I might never understand.

    It sort of feels too complex and very extensive for
    me. I’m taking a look forward on your next put up, I will try to get the dangle
    of it!

  22. cheap flights

    I don’t know if it’s just me or if perhaps everyone else experiencing issues with your website.
    It appears as though some of the written text in your content are running off the screen. Can someone else please
    provide feedback and let me know if this is happening to them too?
    This may be a issue with my browser because I’ve had this happen previously.
    Thank you cheap flights y2yxvvfw

  23. cheap flights

    Hey! Someone in my Facebook group shared this website with us so I came to take a look.
    I’m definitely loving the information. I’m bookmarking and will be tweeting this to my
    followers! Outstanding blog and fantastic design.

  24. cheap flights

    Superb blog! Do you have any helpful hints for
    aspiring writers? I’m planning to start my own website soon but I’m a
    little lost on everything. Would you recommend starting with a free platform like WordPress or
    go for a paid option? There are so many options out there that I’m completely overwhelmed ..

    Any suggestions? Thank you!

  25. cheap flights

    Hey! Do you know if they make any plugins to help with SEO?
    I’m trying to get my blog to rank for some targeted keywords but I’m not seeing very
    good results. If you know of any please share. Appreciate it!

  26. best web hosting 2020

    Wonderful goods from you, man. I’ve bear in mind your stuff prior
    to and you are just extremely magnificent. I really like what you have obtained right here, really like what you’re stating and the way in which in which you are saying it.
    You’re making it entertaining and you continue to care for to stay it wise.
    I can’t wait to read far more from you. This is really a great web site.

  27. Paulrok

    [url=https://buyviagra.us.org/]viagra soft tabs online[/url] [url=https://robaxin365.com/]robaxin medicine[/url] [url=https://sildenafilok.com/]sildenafil soft tabs 100mg[/url] [url=https://flagyltab.com/]metronidazole 500 mg[/url] [url=https://sildenafil.us.org/]viagra for sale online australia[/url]

  28. Paulrok

    [url=https://ivardenafil.com/]buy levitra online in india[/url] [url=https://levitratabs.com/]levitra.com[/url] [url=https://viagrapfz.com/]order viagra online no prescription[/url] [url=https://buyplavix.com/]plavix[/url] [url=https://wellbutrinbup.com/]150 mg wellbutrin[/url]

  29. idn poker

    Whoa! This blog looks just like my old one! It’s on a completely different topic but it has pretty much the same layout and design. Wonderful choice of colors!

  30. Denrok

    [url=http://ivardenafil.com/]brand levitra[/url] [url=http://vardenafillevitra.com/]levitra 20mg tablets price[/url] [url=http://silagratabs.com/]buy silagra uk[/url] [url=http://viagraboom.com/]buy viagra from mexico[/url] [url=http://chloroquinehydroxy.com/]plaquenil 50 mg[/url]

  31. Maryrok

    [url=https://buyalbenza.com/]albenza cost in mexico[/url] [url=https://citalopramm.com/]citalopram headache[/url] [url=https://advairmed.com/]advair diskus otc[/url] [url=https://viagraint.com/]order cheap generic viagra online[/url] [url=https://cytotecmisopostol.com/]misoprostol pills over the counter[/url] [url=https://zoloftsertraline.com/]buy cheap zoloft[/url] [url=https://trazodonepill.com/]buy trazodone without prescription[/url] [url=https://paxiltab.com/]paroxetine brand name in india[/url] [url=https://malegrafxt.com/]malegra 50[/url] [url=https://dapoxetinev.com/]dapoxetine mexico[/url]

  32. Markrok

    [url=https://viagramedi.com/]viagra gel for sale uk[/url] [url=https://nexiuma.com/]nexium 30 mg[/url] [url=https://antabusesale.com/]buy antabuse[/url] [url=https://dapoxetinev.com/]super avana coupon[/url]

  33. 四ツ橋メンズエステ

    You really make it seem really easy along with your presentation however I in finding this
    topic to be really one thing which I feel I would never understand.

    It seems too complex and very extensive for me. I am looking ahead to your next put up, I will try to get the hang of it!

  34. Paulrok

    [url=https://isilagra.com/]silagra 100mg price[/url] [url=https://zoloftsertraline.com/]how to get zoloft online[/url] [url=https://levitratablet.com/]generic levitra best price[/url] [url=https://advairmed.com/]order advair diskus[/url] [url=https://dapoxetinev.com/]where to buy dapoxetine in canada[/url]

  35. brawl stars hack

    I’m impressed, I must say. Rarely do I come across a blog that’s equally educative and engaging, and without a doubt, you have hit the nail on the head.
    The issue is an issue that not enough people are speaking intelligently about.
    Now i’m very happy that I came across this during my search for something regarding this.

  36. Paulrok

    [url=https://hydroxychloroqn.com/]can you buy plaquenil over the counter[/url] [url=https://tadalafildrug.com/]rx tadalafil[/url] [url=https://viagramtf.com/]where can i get viagra[/url] [url=https://plaquenil.us.org/]hydroxychloroquine sulfate tablets[/url] [url=https://sildenafilprod.com/]viagra online with paypal[/url]

Leave a Reply

Your email address will not be published.