Layer 2 Security

When we talk about layer 2 we are talking about layer 2 of OSI model that is Data Link Layer. In data link layer has one broadcast domain but multiple collision domain. It is important to secure this layer as this will be the first line of defense that a user will connect to.

The following are the layer 2 security toolkit.

  • Port Security
  • BDPU Guard
  • Root Guard
  • DHCP Snooping
  • IP source Guard
  • 802.1X
  • Dynamic ARP Inspection
  • Storm Control
  • Access Control List

Port security provides the most basic layer 2 security. For example

Switch2#sh run int g0/0
 Building configuration…
 Current configuration : 188 bytes
 !
interface GigabitEthernet0/0
  description Host1
  switchport access vlan 1000
  switchport mode access
  switchport port-security violation restrict
  switchport port-security mac-address sticky
  switchport port-security

In the above example the port security is enabled using the command switchport port-security and the characteristic of this security is to capture the mac address of the device and on violation it will restrict the traffic.

protect Drops all the packets from the insecure hosts at the port-security process level but does not increment the security-violation count. i.e no logging.
restrict Drops all the packets from the insecure hosts at the port-security process level and increments the security-violation count. i.e logging
shutdown Shuts down the port if there is a security violation.

BPDU are messages that the switches exchange among each other in the root election process in spanning tree and the send these messages periodically to maintain the root or to determine the new root switch if the topology changes.

Often times you don’t want receive BPDU from certain ports. These ports most of the time are access ports to which an end user devices connects. This guards the root switch and avoids a malicious switch from becoming the root if a user connects a rogue switch to a topology by blocking the BPDU’s received on that port. This mechanism is called BPDU Guard.

Switch3#sh run int g0/0
 Building configuration…
 Current configuration : 220 bytes
 !
 interface GigabitEthernet0/0
  description host2
  switchport access vlan 1000
  switchport mode access
  switchport port-security violation restrict
  switchport port-security mac-address sticky
  switchport port-security 
  media-type rj45
  negotiation auto
  spanning-tree bpduguard enable
 end

Another way to maintain the root switch status is by using Root Guard. Root guard if enabled prevents learning about a new root from local ports.

Switch1#sh run int g2/0
 Building configuration…
 Current configuration : 97 bytes
 !
 interface GigabitEthernet2/0
  media-type rj45
  negotiation auto
  spanning-tree guard root
 end

DHCP Snooping is a security feature that acts like a firewall between untrusted hosts and trusted DHCP server. This feature validates DHCP messages received from untrusted sources and filters out invalid messages. DHCP snooping uses a DHCP snooping binding database which contains information about untrusted hosts with leased IP addres

DHCP Snooping is build and maintained per VLAN basis. By default the feature is inactive on all VLANS and has to be enabled first with

ip dhcp snooping

Then it can be applied to the vlans as desired.

ip dhcp snooping vlan 1000
ip dhcp snooping database flash:dhcpsnoop.txt

To specify the trusted port following commands are used

Switch1#sh run int g0/0
 Building configuration…
 Current configuration : 223 bytes
 !
 interface GigabitEthernet0/0
  description dhcp
  switchport access vlan 1000
  switchport mode access
  ip arp inspection trust
  media-type rj45
  negotiation auto
  spanning-tree bpduguard enable
  ip dhcp snooping trust
 end
Switch1#sh ip dhcp snooping
 Switch DHCP snooping is enabled
 Switch DHCP gleaning is disabled
 DHCP snooping is configured on following VLANs:
 1000
 DHCP snooping is operational on following VLANs:
 1000
 DHCP snooping is configured on the following L3 Interfaces:
 Insertion of option 82 is enabled
    circuit-id default format: vlan-mod-port
    remote-id: 0c9e.f443.2800 (MAC)
 Option 82 on untrusted port is not allowed
 Verification of hwaddr field is enabled
 Verification of giaddr field is enabled
 DHCP snooping trust/rate is configured on the following Interfaces:
 Interface                  Trusted    Allow option    Rate limit (pps)
 -----------------------    -------    ------------    ----------------
 GigabitEthernet0/0         yes        yes             unlimited
   Custom circuit-ids:

IP Source Guard prevents IP and/or MAC address spoofing attacks on untrusted layer two interfaces.

When IP source guard is enabled, all traffic is blocked except for DHCP packets. Once the host gets an IP address through DHCP, only the DHCP-assigned source IP address is permitted. You can also configure a static binding instead of using DHCP.

TO enable IP source guard we use the following

Switch1#sh
 *Dec 20 14:52:40.352: %SYS-5-CONFIG_I: Configured from console by console run int g0/0
 Building configuration…
 Current configuration : 255 bytes
 !
 interface GigabitEthernet0/0
  description dhcp
  switchport access vlan 1000
  switchport mode access
  ip arp inspection trust
  media-type rj45
  negotiation auto
  spanning-tree bpduguard enable
  ip verify source
  ip dhcp snooping trust
 end

Now we bind the mac address on that port to the IP address of the device.

Switch1(config)#ip source binding 56d4.cc06.36e5 vlan 1000 192.168.0.1 int g0/0

We can now verify the binding of that IP address with the MAC with

Switch1#sh ip source binding
  MacAddress          IpAddress        Lease(sec)  Type           VLAN  Interface
  ------------------  ---------------  ----------  -------------  ----  --------------------
  C2:2C:47:58:55:32   192.168.0.14     453         dhcp-snooping   1000  GigabitEthernet0/3
  56:D4:CC:06:36:E5   192.168.0.1      infinite    static          1000  GigabitEthernet0/0
  CE:58:33:A9:5D:F5   192.168.0.11     442         dhcp-snooping   1000  GigabitEthernet0/2
  Total number of bindings: 3

As we can see the IP source guard binding is static.

Dynamic ARP inspection (DAI) validates ARP paclets in a network. DAI intercepts, logs,and discards ARP packets with invalid IP to MAC address Bindings.

DAI determines the validitiy of an ARP packet based on the valid IP to MAC address binding stored in trusted database which is created with DHCP snooping. If the ARP packets are received on a trusted interface , the switch forwards the packet without any checks but on an untrusted port, the switch forwards the packet only if it is valid.

Switch1#sh run
 Building configuration…
ip arp inspection vlan 1000
Switch1#sh run int g0/0
 Building configuration…
 Current configuration : 255 bytes
 !
 interface GigabitEthernet0/0
  description dhcp
  switchport access vlan 1000
  switchport mode access
  ip arp inspection trust
  media-type rj45
  negotiation auto
  spanning-tree bpduguard enable
  ip verify source port-security
  ip dhcp snooping trust
 end
Switch1#sh ip arp inspection interfaces
 Interface        Trust State     Rate (pps)    Burst Interval
  ---------------  -----------     ----------    --------------
  Gi0/0            Trusted               None               N/A
  Gi0/1            Untrusted               15                 1
  Gi0/2            Untrusted               15                 1
  Gi0/3            Untrusted               15                 1
  Gi1/0            Untrusted               15                 1
  Gi1/1            Untrusted               15                 1
  Gi1/2            Untrusted               15                 1
  Gi1/3            Untrusted               15                 1
  Gi2/0            Untrusted               15                 1
  Gi2/1            Untrusted               15                 1
  Gi2/2            Untrusted               15                 1
  Gi2/3            Untrusted               15                 1
  Gi3/0            Untrusted               15                 1
  Gi3/1            Untrusted               15                 1
  Gi3/2            Untrusted               15                 1
  Gi3/3            Untrusted               15                 1
Switch1#sh ip arp inspection vlan 1000
 Source Mac Validation      : Disabled
 Destination Mac Validation : Disabled
 IP Address Validation      : Disabled
 Vlan     Configuration    Operation   ACL Match          Static ACL
  ----     -------------    ---------   ---------          ----------
  1000     Enabled          Active
 Vlan     ACL Logging      DHCP Logging      Probe Logging
  ----     -----------      ------------      -------------
  1000     Deny             Deny              Off

Down load the GNS3 lab for practice here

Comments

  1. Hertha Gwalthney

    You are my inhalation , I possess few blogs and rarely run out from to post .I believe this internet site contains some rattling superb information for everyone. “He is able who thinks he is able.” by Buddha.

  2. Reyna Arcudi

    I think this is one of the most vital information for me. And i am glad reading your article. But want to remark on some general things, The web site style is ideal, the articles is really great : D. Good job, cheers

  3. g her

    For latest information you have to pay a quick visit web and on internet I found this web site as a finest site for most
    recent updates.

  4. way g

    I was recommended this website via my cousin. I
    am now not certain whether or not this publish is written by way of him as nobody else understand such particular about my trouble.

    You’re wonderful! Thank you!

  5. g its

    hello there and thank you for your information – I have certainly picked up something new from right here.
    I did however expertise a few technical issues using this site, since I experienced to reload the site lots of times previous to I could get it to load correctly.
    I had been wondering if your web hosting is OK? Not that I am complaining, but slow loading instances times will sometimes affect your placement in google and could damage your high-quality
    score if ads and marketing with Adwords. Well I’m adding this RSS to
    my e-mail and could look out for a lot more of your respective exciting content.

    Make sure you update this again soon.

  6. tinyurl.com

    Hi there! Do you use Twitter? I’d like to follow you if that would be ok.
    I’m definitely enjoying your blog and look forward to new
    updates.

  7. tinyurl.com

    Heya i’m for the first time here. I came across this board and I in finding It truly useful & it helped me
    out much. I hope to present one thing back and help others such as you helped me.

  8. cbd oil that works 2020

    I’m really loving the theme/design of your website.

    Do you ever run into any web browser compatibility problems?

    A couple of my blog readers have complained about my blog not operating correctly in Explorer but looks great
    in Chrome. Do you have any recommendations to help fix this problem?

  9. cbd oil that works 2020

    The other day, while I was at work, my sister stole
    my iPad and tested to see if it can survive a 25 foot drop, just
    so she can be a youtube sensation. My iPad is now destroyed and she has 83 views.

    I know this is totally off topic but I had to share it with someone!

  10. website hosting

    Write more, thats all I have to say. Literally, it seems as though you relied on the video to make
    your point. You obviously know what youre talking about, why throw away your
    intelligence on just posting videos to your blog when you could be giving us something enlightening to read?

  11. web hosting companies

    Its such as you learn my thoughts! You seem to grasp so much approximately this,
    like you wrote the e-book in it or something. I believe that you simply could do with some % to drive
    the message house a little bit, but other than that, this is
    excellent blog. A fantastic read. I’ll definitely be back.

  12. momondo flights cheap

    My brother suggested I might like this website.
    He was entirely right. This post actually made my day.
    You can not imagine just how much time I had spent for
    this information! Thanks!

  13. web hosting services

    I must thank you for the efforts you have put in writing this site.
    I’m hoping to check out the same high-grade blog posts from you later
    on as well. In fact, your creative writing abilities
    has motivated me to get my own website now 😉

  14. website hosting companies

    What i do not realize is actually how you are not really a lot more smartly-preferred than you may be now.
    You’re so intelligent. You already know therefore considerably in relation to this topic, made me individually consider
    it from numerous varied angles. Its like men and women aren’t interested except it is something to
    accomplish with Girl gaga! Your personal stuffs outstanding.
    Always handle it up!

  15. best web hosting 2020

    Thanks for one’s marvelous posting! I really enjoyed reading it,
    you’re a great author. I will be sure to bookmark your blog and may come back from now on. I want to
    encourage you to ultimately continue your great job, have a nice holiday weekend!

  16. website host

    I think that is one of the such a lot important information for me.
    And i am happy studying your article. But want to commentary on few basic things,
    The site style is ideal, the articles is truly excellent : D.
    Good process, cheers

  17. web hosting sites

    Hi there! Quick question that’s totally
    off topic. Do you know how to make your site mobile
    friendly? My weblog looks weird when viewing from my apple iphone.
    I’m trying to find a template or plugin that might be able to resolve this problem.
    If you have any recommendations, please share.
    With thanks!

  18. web hosting company

    It’s perfect time to make some plans for the future and it’s time to be happy.
    I have read this post and if I could I wish to suggest you few interesting things or
    advice. Maybe you can write next articles referring
    to this article. I wish to read even more things about
    it!

  19. cheap flights

    May I just say what a relief to find an individual who actually knows
    what they are discussing online. You certainly realize how to bring a problem to light and make it important.
    More and more people must look at this and understand
    this side of the story. It’s surprising you aren’t more popular since you definitely possess the gift.

  20. cheap flights

    Hey There. I found your blog using msn. This is an extremely
    well written article. I will be sure to bookmark it and return to read more of your useful information. Thanks
    for the post. I’ll definitely comeback. cheap flights y2yxvvfw

  21. cheap flights

    Hmm it looks like your site ate my first comment (it was
    super long) so I guess I’ll just sum it up what I had written and say,
    I’m thoroughly enjoying your blog. I as well am
    an aspiring blog blogger but I’m still new to everything.
    Do you have any helpful hints for rookie blog writers?
    I’d definitely appreciate it. cheap flights 2CSYEon

  22. cheap flights

    Aw, this was a really nice post. Spending some time and actual effort to
    produce a superb article… but what can I say… I put things off a
    lot and never manage to get anything done.
    y2yxvvfw cheap flights

  23. cheap flights

    I’m truly enjoying the design and layout of your site.
    It’s a very easy on the eyes which makes
    it much more pleasant for me to come here and visit more
    often. Did you hire out a developer to create your theme?
    Outstanding work!

  24. cheap flights

    Neat blog! Is your theme custom made or did you download it from somewhere?
    A theme like yours with a few simple adjustements would really make my blog shine.

    Please let me know where you got your design. Many thanks

  25. cheap flights

    Hi, I do believe this is a great site. I stumbledupon it 😉 I’m
    going to come back once again since I book marked it. Money and freedom
    is the best way to change, may you be rich and continue
    to help other people.

  26. cheap flights

    wonderful post, very informative. I’m wondering why the opposite experts of this sector do not realize this.
    You must continue your writing. I am sure, you have a
    huge readers’ base already! 31muvXS cheap flights

  27. cheap flights

    I was recommended this web site by my cousin. I’m not sure whether this post is
    written by him as no one else know such detailed about
    my difficulty. You’re incredible! Thanks!

  28. black mass

    We stumbled over here different website and thought I might as well check things out.
    I like what I see so now i am following you. Look forward to exploring your web page
    for a second time.

  29. black mass

    Hello there! Would you mind if I share your blog with my myspace group?
    There’s a lot of people that I think would really appreciate your content.
    Please let me know. Many thanks

  30. web hosting sites

    Greetings I am so thrilled I found your blog page, I really found you
    by mistake, while I was researching on Askjeeve for
    something else, Anyways I am here now and would just like to say
    thanks a lot for a remarkable post and a all round enjoyable blog (I also love the theme/design), I don’t have time to
    read it all at the moment but I have book-marked it and also added your RSS feeds, so when I have time I will be
    back to read a great deal more, Please do keep up the awesome job.

  31. website hosting

    I have been surfing online more than 3 hours these days,
    but I by no means found any fascinating article like
    yours. It is beautiful worth sufficient for me. In my opinion, if all web owners and bloggers made good content
    material as you did, the web will probably be a lot more useful than ever before.

  32. best web hosting 2020

    This design is incredible! You obviously know how to keep a reader entertained.
    Between your wit and your videos, I was almost moved to start my own blog (well, almost…HaHa!) Excellent job.
    I really enjoyed what you had to say, and more than that, how you presented it.
    Too cool!

  33. buy hacklink

    Likes on Instagram can improve your brand’s engagement numbers. When you buy Instagram likes you get more engagement on your profile which means more reputation.

  34. brightest headlamp

    Write more, thats all I have to say. Literally, it seems as though
    you relied on the video to make your point. You clearly know what youre talking about,
    why throw away your intelligence on just posting videos
    to your blog when you could be giving us something enlightening
    to read?

  35. Hairstyles

    Good ?I should definitely pronounce, impressed with your web site. I had no trouble navigating through all tabs as well as related information ended up being truly easy to do to access. I recently found what I hoped for before you know it at all. Reasonably unusual. Is likely to appreciate it for those who add forums or something, web site theme . a tones way for your client to communicate. Excellent task..

  36. zortilo nrel

    I have read a few good stuff here. Definitely price bookmarking for revisiting. I wonder how much attempt you place to make this kind of wonderful informative website.

  37. Colby

    Wonderful beat ! I would like to apprentice at the same time as you amend your site, how can i subscribe for a blog web
    site? The account aided me a applicable deal.
    I had been tiny bit acquainted of this your broadcast offered vivid transparent idea

  38. Lloyd

    Great post. I was checking constantly this blog and I am impressed!
    Extremely useful information specifically the last
    part 🙂 I care for such info a lot. I was looking for this particular information for a long
    time. Thank you and best of luck.

  39. Gabrielle

    Heya i’m for the first time here. I came across this board and I find It
    really useful & it helped me out a lot. I hope to give something back and help others like you helped
    me.

  40. cheap flights

    Have you ever thought about writing an ebook or
    guest authoring on other websites? I have a blog based on the
    same ideas you discuss and would really like to have you share some stories/information. I know my subscribers would value your work.
    If you’re even remotely interested, feel free to send me an email.

  41. cheap flights

    Howdy! This article could not be written any better! Reading through this post reminds
    me of my previous roommate! He constantly kept talking about this.

    I’ll forward this information to him. Pretty sure he’s going to have a good read.

    Thank you for sharing!

  42. cheap flights

    Right here is the right web site for everyone who hopes to
    understand this topic. You know a whole lot its almost tough to argue with you (not that I personally would want to…HaHa).

    You certainly put a brand new spin on a topic that has been written about for
    many years. Great stuff, just great!

  43. tinyurl.com

    I think what you published made a lot of sense. But, consider this, suppose you added a little information? I am not suggesting your information isn’t good,
    however what if you added a headline that makes people desire more?

    I mean Layer 2 Security is kinda vanilla. You should
    peek at Yahoo’s front page and see how they create article headlines to get people to
    open the links. You might try adding a video or a related picture or two to grab people
    excited about everything’ve got to say. Just my opinion, it could bring your website a little livelier.

  44. cheap flights

    What i do not understood is in truth how you are no longer
    really much more well-preferred than you might be right now.
    You’re so intelligent. You know thus significantly relating
    to this matter, made me individually imagine it from a lot of
    numerous angles. Its like men and women aren’t interested until it’s something to accomplish with Lady gaga!
    Your own stuffs outstanding. At all times maintain it up!

  45. http://tinyurl.com

    I am not sure where you are getting your info, but good topic.
    I needs to spend some time learning more or
    understanding more. Thanks for magnificent information I was looking for this information for my mission.

  46. balancecbd

    I’m not sure why but this site is loading extremely slow for me.

    Is anyone else having this problem or is it a issue on my end?
    I’ll check back later and see if the problem still exists.

  47. web hosting

    Heya i’m for the first time here. I came across this board and
    I find It really useful & it helped me out a lot.
    I hope to give something back and help others like you aided
    me.

  48. Lisandra Rutigliano

    Buy hydrocodone online from a reputable dealer can be convenient for anyone who wants to get their hands on this medication that is highly prescribed by physicians and police officers. It can be used for managing pain, the common cold, and the flu. However, buying it online can also be beneficial for people who are not licensed to deal with narcotic pain relievers. In fact, they can be purchased without a prescription, and they can also be ordered through vending machines or over the phone.

  49. gamefly

    Its like you learn my thoughts! You seem to understand a lot approximately this, such as
    you wrote the ebook in it or something. I
    believe that you simply can do with a few percent to pressure the message house a little bit, but instead of that, this is
    fantastic blog. A fantastic read. I’ll certainly be back. ps4 games 185413490784 ps4 games

  50. j.mp

    Wow! At last I got a webpage from where I know how to really take valuable data regarding my study and knowledge.
    games ps4 185413490784 games ps4

  51. ps4 games

    Greetings from Idaho! I’m bored at work so I decided to check out your website on my
    iphone during lunch break. I really like the info you present here and can’t wait to take a look when I get home.
    I’m shocked at how quick your blog loaded on my cell phone ..
    I’m not even using WIFI, just 3G .. Anyways, good site!

  52. web hosting

    This is a very good tip especially to those fresh to the blogosphere.

    Simple but very accurate information… Appreciate your sharing this
    one. A must read post!

  53. web hosting

    Hey! Would you mind if I share your blog with my myspace group?
    There’s a lot of people that I think would really enjoy your content.
    Please let me know. Thanks

  54. sooxy heedge

    Порно Фильмы – Огромная онлайн коллекция с бесплатным порно видео и ежедневными обновлениеми на любой вкус. Русское, домашнее, секс видео зрелых, анал, красивые девушки, бдсм, видео молодых, жены, измены, сиськи и другие категории. Смотреть порно фильмы можно как на компьютере так и на мобильном телефоне!
    prolesbi.com

  55. ShELL DoWNLoad

    When I initially commented I clicked the “Notify me when new comments are added” checkbox and now each
    time a comment is added I get three emails with the same comment.
    Is there any way you can remove me from that service?
    Thank you!

  56. antalya böcek ilaçlama

    We are a group of volunteers and starting a new scheme in our community.
    Your web site offered us with useful info to work on. You have done an impressive job and our entire community will probably be thankful to you.

  57. indir

    An outstanding share! I have just forwarded this onto a friend who had been doing a little research
    on this. And he actually bought me breakfast because I found it for him…
    lol. So let me reword this…. Thanks for the meal!!
    But yeah, thanx for spending some time to talk about this subject here on your web
    site.

  58. Retinol Serum

    What’s Happening i am new to this, I stumbled upon this I’ve discovered
    It positively useful and it has aided me out loads. I’m hoping to give a contribution & help different users like
    its aided me. Great job.

  59. Markrok

    [url=https://asmpharmacy.com/]no script pharmacy[/url] [url=https://viagrawrp.com/]viagra pills discount[/url] [url=https://opacialis.com/]where can i get cialis over the counter[/url]

  60. 0mniartist

    Wow, amazing blog structure! How lengthy have you been running a blog for?
    you make blogging glance easy. The whole glance of your site is excellent,
    as neatly as the content!
    0mniartist asmr

  61. asmr https://0mniartist.tumblr.com

    I love your blog.. very nice colors & theme.
    Did you design this website yourself or did you hire
    someone to do it for you? Plz respond as I’m looking to construct my
    own blog and would like to know where u got this from.
    thanks a lot 0mniartist asmr

  62. Pingback: sildenafil directions

  63. Pingback: buy cialis india pharmacy

  64. Pingback: donde comprar online levitra seguro

  65. Pingback: how to buy sildenafil online

  66. Pingback: buy viagra cost after insurance

  67. Pingback: jon jones over the counter cialis

  68. http://bit.ly

    I think that everything wrote made a bunch of sense. However, think on this, what if you composed a
    catchier title? I mean, I don’t wish to tell you how to run your website, however what if you added
    a post title that makes people desire more?
    I mean Layer 2 Security is a little boring. You ought to glance at Yahoo’s home
    page and see how they create post titles to get viewers to click.
    You might add a related video or a picture or two
    to get readers interested about what you’ve written. Just my opinion,
    it might bring your website a little bit more interesting.
    0mniartist asmr

  69. Paz Fortier

    You made some really good points there. I checked
    on the net for more information about the issue and found most individuals will
    go along with your views on this site.

  70. Daniel Jackson

    Wonderful work! That is the type of info that are meant to be shared across the internet. Shame on the seek engines for no longer positioning this publish upper! Come on over and discuss with my web site . Thank you =)

  71. David Joseph

    Thanks for the points you have shared here. One more thing I would like to state is that laptop or computer memory specifications generally rise along with other advances in the technologies. For instance, as soon as new generations of processors are brought to the market, there’s usually a related increase in the size and style calls for of both computer system memory and hard drive space. This is because software program operated through these cpus will inevitably increase in power to benefit from the new engineering.

  72. Gary Jordan

    Pretty section of content. I just stumbled upon your web
    site and in accession capital to assert that I get actually
    enjoyed account your blog posts. Any way I’ll be subscribing to your
    augment and even I achievement you access consistently rapidly.

  73. Tomas Garber

    You made some really good points there. I checked
    on the net for more info about the issue and found most people will go along with your views on this web site.

  74. Andrew Alcoran

    Hi! I’ve been reading your web site for a long time now and finally got the bravery
    to go ahead and give you a shout out from Porter
    Tx! Just wanted to mention keep up the excellent job!

  75. bit.ly

    Wonderful items from you, man. I’ve be aware your stuff previous to and you
    are simply too wonderful. I really like what you’ve received right here,
    really like what you’re stating and the way in which wherein you say it.
    You are making it entertaining and you continue to take care of to stay
    it wise. I can’t wait to learn far more from you. That is really
    a wonderful site. asmr 0mniartist

  76. Sofia Cunningham

    Woah! I’m really loving the template/theme of this blog.
    It’s simple, yet effective. A lot of times it’s challenging to get that “perfect balance” between user friendliness and appearance.
    I must say that you’ve done a awesome job with this.
    In addition, the blog loads super quick for
    me on Chrome. Excellent Blog!

  77. Jill Melendez

    I have been surfing online more than three hours today, yet
    I never found any interesting article like yours. It’s pretty worth enough for me.
    In my opinion, if all website owners and bloggers made good content as you did, the web will be much more useful than ever before.

  78. Alberto Lightfoot

    Howdy would you mind stating which blog platform you’re working with?
    I’m looking to start my own blog in the near
    future but I’m having a hard time deciding between BlogEngine/Wordpress/B2evolution and Drupal.
    The reason I ask is because your design seems different then most
    blogs and I’m looking for something completely unique. P.S Apologies for getting off-topic but I had to ask!

  79. Mary Pitts

    You made some good points there. I looked on the net
    to find out more about the issue and found most people will
    go along with your views on this web site.

  80. Pingback: amoxicillin and wine interaction

  81. Pingback: can i take tylenol with amoxicillin

  82. Pingback: azithromycin bladder infection

  83. Pingback: o celebrex

  84. Pingback: dogs take celebrex

  85. Pingback: is keflex a cephalosporin

  86. Pingback: keflex 500 mg dosing

  87. Pingback: duloxetine reviews

  88. Pingback: desipramine cymbalta

  89. Pingback: nizagara vs viagra australia

  90. Tammie Sparrow

    Hola! I’ve been reading your blog for some time now and finally got
    the bravery to go ahead and give you a shout out from Kingwood Tx!
    Just wanted to say keep up the fantastic work!

  91. Pingback: otc version of cialis

  92. Gary Cromwell

    It’s the best time to make some plans for the future and it’s time to be happy.
    I have read this post and if I could I desire to suggest you few interesting
    things or advice. Maybe you could write next articles referring to this
    article. I wish to read even more things about it!

  93. Sherry Harris

    Howdy I am so delighted I found your weblog, I really found you by error,
    while I was researching on Google for something else, Nonetheless
    I am here now and would just like to say thanks a lot for a remarkable post and a all round enjoyable blog (I also love
    the theme/design), I don’t have time to read it all at the moment but I have saved it
    and also added in your RSS feeds, so when I have time I will be back to read a lot more, Please do keep up the great jo.

  94. Pingback: buy generic cialis online australia

  95. Nancy Swanson

    Greetings! I’ve been reading your site for a while now and finally got
    the bravery to go ahead and give you a shout out from Huffman Texas!
    Just wanted to tell you keep up the good job!

  96. Margaret Scanlan

    hi!,I really like your writing so so much! share we keep in touch
    extra approximately your article on AOL?
    I need a specialist on this area to resolve my
    problem. May be that is you! Taking a look forward to see you.

  97. Pingback: cialis plans to go otc

  98. Pingback: cheapest generic viagra 100mg

  99. Richard Chavez

    Howdy just wanted to give you a quick heads up.
    The words in your content seem to be running off the screen in Internet explorer.
    I’m not sure if this is a format issue or something to do with browser
    compatibility but I thought I’d post to let you know.
    The design look great though! Hope you get the problem solved soon. Many thanks

  100. Pingback: comprar sildenafil viagra

  101. John Williams

    It’s the best time to make some plans for the
    future and it’s time to be happy. I have learn this put up and if I may just I wish
    to suggest you few attention-grabbing things or suggestions.
    Maybe you can write subsequent articles regarding this article.
    I want to learn more issues approximately it!

  102. Pingback: sildenafil rx coupon

  103. Pingback: sildenafil 25 mg online

  104. Pingback: order online limits tadalafil

  105. Pingback: buy cialis online mexico

  106. Pingback: pas cher viagra soft 50 en online

  107. Harold Valerius

    I just couldn’t go away your web site prior to suggesting that I extremely loved the standard information a person provide for your
    guests? Is gonna be back ceaselessly to inspect new posts

  108. Pingback: order generic cialis from canada

  109. Jack Farmer

    It is the best time to make some plans for the future and it’s time to
    be happy. I’ve read this post and if I could I wish to suggest you some interesting
    things or advice. Maybe you can write next articles referring to this article.
    I wish to read even more things about it!

  110. Pingback: free cialis australia

  111. Pingback: comprar viagra pfizer

  112. Pingback: cialis 20mg price in canada

  113. Tamica Richard

    Hello, i think that i saw you visited my blog so i came to “return the favor”.I am attempting
    to find things to improve my web site!I suppose its ok to use
    a few of your ideas!

  114. Alicia Tarrant

    I will right away snatch your rss as I can not find your e-mail subscription hyperlink or newsletter service.
    Do you have any? Kindly allow me recognize so that I could subscribe.
    Thanks.

  115. Pingback: sildenafil prices canada

  116. Lori Barnes

    I’ve been browsing online more than three hours nowadays, but I never found
    any interesting article like yours. It’s lovely price enough for
    me. In my opinion, if all web owners and bloggers made excellent content as you did, the net can be
    much more useful than ever before.

  117. Stacy Gurney

    I will immediately seize your rss as I can’t find your e-mail subscription link or newsletter service.
    Do you have any? Please let me know so that I may subscribe.

    Thanks.

  118. Pingback: best site to buy generic cialis

  119. Charlene Warrick

    I just couldn’t leave your web site prior to suggesting that
    I actually enjoyed the standard information a person provide in your visitors?
    Is gonna be back continuously in order to inspect new posts

  120. Pingback: generic cialis usa pharmacy

  121. Stephen Dowland

    I simply could not go away your web site before suggesting that I actually
    loved the standard information an individual
    supply to your visitors? Is gonna be again steadily in order to investigate cross-check new posts

  122. Pingback: acheter viagra 100mg pfizer

  123. John Symonds

    I’ve been surfing on-line more than three hours lately, but
    I by no means discovered any attention-grabbing article
    like yours. It’s beautiful value sufficient for me.
    In my view, if all webmasters and bloggers made just right content
    as you did, the web will likely be a lot more helpful than ever before.

  124. Gustavo Brooks

    Hello just wanted to give you a quick heads up.
    The text in your article seem to be running off the screen in Opera.
    I’m not sure if this is a format issue or something
    to do with browser compatibility but I figured I’d post to
    let you know. The layout look great though!
    Hope you get the issue resolved soon. Thanks

  125. Pingback: compra online cialis

  126. Pingback: sister helps brother viagra problems

  127. Pingback: cialis 20mg price at walmart

  128. Loyd Messer

    I like what you guys are usually up too. This kind of
    clever work and exposure! Keep up the fantastic works guys
    I’ve included you guys to my blogroll.

  129. Pingback: kelly hu viagra 2015

  130. Pingback: price of 50mg viagra

  131. Pingback: viagra online purchase india

  132. Pingback: acheter cialis canada

  133. Pingback: buy cialis online fast delivery

  134. Pingback: cialis 2018 commercial

  135. Pingback: cheapest generic cialis australia

  136. Maryrok

    [url=https://pharmacypsi.com/]best online pharmacy india[/url] [url=https://gutpills.com/]sildenafil 10 mg daily[/url] [url=https://levipharmacy.com/]cheap canadian pharmacy[/url] [url=https://365tablets.com/]strattera 18 mg price[/url] [url=https://bluepviagra.com/]sildenafil 100mg from india[/url] [url=https://cialisdtab.com/]cialis 1800 mg[/url] [url=https://viagrango.com/]viagra canada drugstore[/url] [url=https://pharmacynrg.com/]canadian family pharmacy[/url] [url=https://pharmnear.com/]ivermectin 4000[/url] [url=https://mviagra.com/]sildenafil 10 mg[/url]

  137. gamefly my

    Greetings! Very useful advice in this particular
    post! It’s the little changes that make the most important changes.
    Thanks for sharing!

  138. asmr are

    Asking questions are actually fastidious thing if you are not understanding anything totally, but
    this paragraph presents good understanding even.

  139. their asmr

    Wonderful goods from you, man. I’ve understand your stuff previous to and you’re just too wonderful.
    I really like what you have acquired here, really like what you are stating and
    the way in which you say it. You make it entertaining and you still care for to keep
    it wise. I can not wait to read far more from you.
    This is really a great site.

  140. asmr off

    No matter if some one searches for his essential thing, thus he/she desires to be
    available that in detail, thus that thing is maintained over here.

  141. Pingback: buy cialis rush

  142. Pingback: Zakhar Berkut hd

  143. Pingback: 4569987

  144. a gamefly

    Hi would you mind letting me know which hosting company you’re using?
    I’ve loaded your blog in 3 completely different internet browsers and I must say this blog loads a
    lot quicker then most. Can you suggest a good internet hosting provider at a reasonable price?
    Thanks, I appreciate it!

  145. escort

    Right here is the right webpage for anybody who would
    like to understand this topic. You realize so much its
    almost hard to argue with you (not that I really will
    need to…HaHa). You definitely put a new spin on a subject which has been discussed for ages.
    Wonderful stuff, just great!

  146. Pingback: news news news

  147. Group sex

    Opposition to keeping chastity means that when your daughter wants to engage with other people, she will engage with others, and whoever she wants to engage with. This is how your wife is sexually free? Click:Forced rape.

  148. where asmr

    Hey! I know this is somewhat off topic but I was wondering which blog platform
    are you using for this site? I’m getting sick and tired of WordPress because
    I’ve had problems with hackers and I’m looking at alternatives
    for another platform. I would be great if you could point me in the
    direction of a good platform.

  149. Jacklyn

    Excellent website you have here but I was wondering if you knew of any user discussion forums
    that cover the same topics talked about here? I’d really love to be a part of group where I can get responses from other
    experienced individuals that share the same interest. If you have any suggestions, please let me know.

    Thanks a lot!

  150. Pingback: psy

  151. Pingback: psy2022

  152. Pingback: projectio-freid

  153. of asmr

    wonderful post, very informative. I’m wondering why the other specialists
    of this sector don’t realize this. You must continue your writing.
    I’m confident, you have a great readers’ base already!

  154. EN iyi leke kremi

    En iyi Leke Kremi, Leke Kremi

    Cilt lekelerinin bir çok türü vardır sadece güneş, doğum ve sivilce lekeleri sıklıkla karşılaştığımız leke türleridir
    3. Özellikle ozon tabakasının giderek hasar görmesiyle UV ışınlarının zararlı etkilerine maruz kalma
    riskimiz artmıştır.
    3Güneş dolaysıcaklıkyla da ultraviyole ışınları lekelerin oluşmasında
    ya da koyulaşmasında en önemli etkenlerden biridir.

    Yüzümüzde ortaya çıkan lekeler ara sıra dış imajmüzü ve psikolojimizi
    olumsuz etkisinde bırakır.

    o halde hemen EN iyi leke kremi ile tanışmalısınız..

  155. Adult fiction

    Get up early in the morning and make love, exercise and supplement calcium. It’s good to take time out at noon to increase feelings. Call the bed before going to bed at night, tomorrow will be very strong. Get up in the middle of the night and have a fight to enhance immunity from catching a cold! Click:oral sex.

  156. http://bit.ly/3buqqWd

    scoliosis
    This design is incredible! You certainly know
    how to keep a reader entertained. Between your
    wit and your videos, I was almost moved to start my own blog (well, almost…HaHa!) Wonderful job.

    I really loved what you had to say, and more
    than that, how you presented it. Too cool! scoliosis

  157. Pingback: kinoteatrzarya.ru

  158. Pingback: topvideos

  159. Pingback: video

  160. where to buy cialis cheap

    My coder is trying to convince me to move to .net from
    PHP. I have always disliked the idea because of the expenses.

    But he’s tryiong none the less. I’ve been using WordPress on numerous websites for about a year and am concerned about switching to another platform.
    I have heard good things about blogengine.net.
    Is there a way I can import all my wordpress posts into it?
    Any help would be really appreciated! http://cleckleyfloors.com/cialis

  161. Pingback: afisha-kinoteatrov.ru

  162. Pingback: Ukrainskie-serialy

  163. Sex toys

    My dream: I have something to do as a secretary, but I have nothing to do as a secretary, but the reality is: I can’t do something as a secretary, and I can’t do something as a secretary. Click:Fuck.

  164. Sam Dillin

    If you want to be young, you need a real person wig, thin hair and white hair, and you still want to slap them? Hurry up and find Do Laimi to send additional issuance! Want to change hairstyle anytime? Do Laimi can wear a real wig.

  165. Pingback: site

  166. http://t.co/AXPmcbSQ2y

    scoliosis
    It’s perfect time to make some plans for the future and it’s time to
    be happy. I have read this post and if I could I desire to suggest
    you some interesting things or tips. Maybe you can write next articles referring to this article.

    I desire to read more things about it! scoliosis

  167. Carita Sheive

    If you want to be young, you need a real person wig, thin hair and white hair, and you still want to slap them? Hurry up and find Do Laimi to send additional issuance! Want to change hairstyle anytime? Do Laimi can wear a real wig.

  168. web site

    I wanted to thank you for this fantastic read!! I ccertainly loved
    every little bit of it. I have got yoou book marked to
    looik at new things you post…
    web site

  169. Adult porn

    How can students who are full of sexual fantasies read into textbooks? How can a staff full of sexual fantasies do a good job? One thing is certain: a large number of people are ruined by sexual fantasies. Click:Fuck.

  170. Miarok

    [url=https://onetabstore.com/]can i buy amoxicillin over the counter[/url] [url=https://tadalafilchemi.com/]cialis south africa price[/url] [url=https://cialis2x.com/]india tadalafil[/url] [url=https://formpills.com/]buy gabapentin cheap[/url] [url=https://upspills.com/]vardenafil drug[/url]

  171. spirit hole

    I’m really enjoying the design and layout of your
    website. It’s a very easy on the eyes which makes it much more pleasant for me to come here and visit more often. Did
    you hire out a designer to create your theme? Exceptional work!

  172. are asmr

    I was wondering if you ever thought of changing the page layout
    of your blog? Its very well written; I love what youve got to say.
    But maybe you could a little more in the way of content so people could
    connect with it better. Youve got an awful lot
    of text for only having one or 2 images. Maybe you could space it out better?

  173. C Vitamini Serumu

    HC Vitamin-C Serum, özel olarak geliştirilmiş yüksek stabilite özelliğine sahip Lipozomal Vitamin-C
    kompleksi ve en ileri düzeyde konsantre edilmiş saf Hyaluronik Asit ile formülize edilen yoğun bakım serumudur.

    Liposomal C Vitamini Serumu , Saf Hyalüronik Asit, Yeniden Diriliş Bitkisi (Glyceryl Glucoside), Pentavitin (Saccharide Isomerate)
    ve Anadenanthera Colubrina Bark Extract içeren formülü ile ciltte oluşabilecek
    lekeleri minimuma indirmeye ve kırışıklıkları önlemeye yardımcı olur.
    Çevresel faktörlere karşı etkili korumayı destekler.
    Yoğun nemlendirici ve tazeleyici özelliği
    sayesinde cildin sıkılığını arttırır ve aydınlanmasını destekler.
    Ciltteki ton eşitsizliklerine karşı mücadele eder.

    Kozmetik piyasasında bulunan C vitamini serumu bir çoğunda Askorbik Asit’in stabil olmayan %15’lük formu kullanılmaktadır.
    Bu ürünler stabil olmadıklarından zamanla okside olur, rengi koyulaşır ve doğal olarak da zamanla etkinliğini kaybeder.

    HC Vitamin-C Serum içerisinde stabil formda ve lipozomal
    kapsül şeklinde %3′ lük Etil Askorbik Asit kullanılmıştır.
    Lipozomal taşıyıcı sistemler, hedef noktaya aktif maddeyi taşımak için geliştirilen üst düzey
    teknolojidir. Ürün içindeki aktif madde (C VİTAMİNİ) cilt altına indikten sonra çözülür ve daha kısa
    sürede maksimum etki gösterir.

    Bu sayede hem uzun raf ömrü boyunca stabilitesini kaybetmeden etkisini sürdürür,
    hem de etkisi diğer formlara göre çok daha başarılıdır.

    c vitamini serumu

  174. Oren Wilcutt

    ブランドスーパーコピー後払い,スーパーコピーブランド代引き.

  175. cho thuê phòng hội nghị

    It is the best time to make a few plans for the future and it is time to be happy. I’ve read this post and if I may I want to suggest you some interesting things or suggestions. Maybe you can write next articles referring to this article. I wish to learn more issues about it!

  176. Jeanmarie Fuston

    In the grand design of things you actually get a B+ just for effort and hard work. Where exactly you confused me was first on your particulars. You know, it is said, details make or break the argument.. And it could not be more correct at this point. Having said that, let me inform you just what exactly did give good results. The article (parts of it) is really engaging and that is probably why I am taking the effort to comment. I do not really make it a regular habit of doing that. 2nd, despite the fact that I can see a leaps in reasoning you make, I am definitely not convinced of how you appear to connect the details which in turn help to make your final result. For the moment I shall yield to your issue but trust in the foreseeable future you actually link your dots much better.

  177. Sex toys

    Why do people need to be called humans? One must have dignity and not mess around like a dog. Otherwise, your psychology and virtue will be the same as that of a dog. Click:Adult porn.

  178. 스포츠사이트

    Have you ever considered about including a little bit more than just your articles? I mean, what you say is valuable and all. But think about if you added some great gr스포츠사이트
    aphics or videos to give your posts more, « pop »! Your content is excellent but with pics and clips, this blog could certainly be one of the greatest in its field. Awesome blog!|

  179. Wife Exchange Club

    Shou is only temporary, what’s wrong, and there is no saying that it will be kept for a lifetime. This is good for human health and quality. There are so many venereal diseases now. . Affect social development and eugenics. Click:rape.

  180. Janyce Tinstman

    If you want to be young, you need a real person wig, thin hair and white hair, and you still want to slap them? Hurry up and find Do Laimi to send additional issuance! Want to change hairstyle anytime? Do Laimi can wear a real wig.

  181. 스피드바카라

    I?m amazed, I have to claim. Truly rarely do I come across a blog that?s both educative as well as amusing, and also let me inform y
    스피드바카라
    ou, you have actually hit the nail on the head. Your suggestion is exceptional; the concern is something that not nearly enough individuals are speaking smartly about. I am very happy that I came across this in my look for something connecting to this.

  182. fun88

    It’s appropriate time to make a few plans for the future and it’s time to be
    happy. I have read this publish and if I could I wish to recommend you few attention-grabbing things or tips.

    Maybe you could write subsequent articles regarding
    this article. I want to learn more things about
    it!

  183. Sex slave

    A coquettish woman may not be sexy because she has released too much sexual energy; a sexy woman may not be coquettish because she has abundant sexual energy in her body. Click:Being fucked.

  184. 스포츠사이트

    Unquestionably believe that which you said. Your favorite justification appeared to be on the web the easiest thing to be aware of. I say to you, I definitely get annoyed while people consider worries that they just do not know about. You managed스포츠사이트 to hit the nail upon the top as well as defined out the whole thing without having side effect , people could take a signal. Will probably be back to get more. Thanks|

  185. 토토

    Have you ever considered about including a little bit more than just your articles? I mean, what you say is valuable and all. But think about if you added some great graphics or videos to give your posts more, « pop »! Your content is토토
    xcellent but with pics and clips, this blog could certainly be one of the greatest in its field. Awesome blog!|

  186. are dating sites

    Does your website have a contact page? I’m having a tough time locating it but, I’d
    like to send you an e-mail. I’ve got some suggestions for your blog you might be interested in hearing.
    Either way, great blog and I look forward to seeing it improve over
    time.

  187. helpful hints

    Neat blog! Is your theme custom made or did you download it from somewhere? A design like yours with a few simple adjustements would really make my blog shine. Please let me know where you got your theme. Bless you|

  188. price of tadalafil 20mg

    Just want to say your article is as surprising. The clearness on your put up is simply
    great and that i can assume you are an expert on this subject.

    Fine along with your permission allow me to clutch your feed to stay updated with drawing close post.
    Thanks 1,000,000 and please continue the gratifying work. http://cialllis.com/

  189. update covid-19

    This design is wicked! You definitely know how to keep a reader amused.
    Between your wit and your videos, I was almost moved to start my own blog
    (well, almost…HaHa!) Wonderful job. I really loved what you had to say,
    and more than that, how you presented it. Too cool!

  190. poker idn

    We are a group of volunteers and starting a new scheme in our community.
    Your web site provided us with valuable information to
    work on. You’ve done an impressive job and our whole community will be thankful to you.

  191. the surgery scoliosis

    I’ve been surfing online more than 2 hours today, yet I never found any
    interesting article like yours. It’s pretty worth enough for me.
    Personally, if all webmasters and bloggers made good content
    as you did, the web will be a lot more useful than ever before.

  192. for free dating sites

    Hi, I do believe this is a great web site. I stumbledupon it 😉
    I’m going to come back yet again since i have bookmarked it.

    Money and freedom is the best way to change, may you be rich and continue to guide other
    people.

  193. s128 agen

    Have you ever thought about creating an ebook or
    guest authoring on other sites? I have a blog based upon on the same information you discuss and would love to have you share some stories/information. I
    know my viewers would appreciate your work. If you are even remotely interested, feel free to send me an e-mail.

  194. binance make payment to bitcoin address balance

    Just wish to say your article is as astonishing.

    The clearness on your submit is simply cool and i
    could think you’re knowledgeable in this subject.
    Fine together with your permission allow me to take hold of your RSS feed
    to stay up to date with coming near near post. Thanks 1,000,000 and please continue the gratifying work.

  195. tinyurl.com

    Thanks for the good writeup. It in truth was a enjoyment account it.

    Glance complicated to more introduced agreeable from you!
    However, how could we be in contact?

  196. Anonymous

    Deep in a woman’s heart, there is a fairy-like tenderness and a witch-like terrible. Click:[url=”http://www.bvs.hn/”]sexual intercourse[/url].

  197. http://tinyurl.com

    It’s the best time to make some plans for the future and it’s time to be happy.
    I’ve read this post and if I could I want to suggest
    you few interesting things or advice. Maybe you can write
    next articles referring to this article. I desire to read more
    things about it!

  198. Anonymous

    Men think that there are few women who are suitable for them before marriage, and many who think they are suitable for them after marriage. Click:[url=”https://www.topkopi.net/”]Fuck[/url].

  199. Anonymous

    必利勁(英文名:Priligy 化學名:鹽酸達泊西汀)是目前唯一針對早洩(PE)研發的藥物,也是唯一獲得國家食品藥品監督管理局(CEDA)批準的早洩-[url=”https://lafemme.org/”]必利勁[/url]

  200. Anonymous

    I really appreciate this post. I have been looking everywhere for this! Thank goodness I found it on Bing. You’ve made my day! Thank you again

  201. Anonymous

    威尔刚(viagra,台湾名:威而钢)是由美国辉瑞研制开发的一种口服治疗ED的药物。用于治疗勃起功能障碍以及早泄,对于勃起功能减退与早泄有非常显著的改善–[url=”http://www.usms.ac.ma/”]威而鋼[/url]

  202. binance api yawm sij

    This is the perfect website for anyone who would like to understand this topic.
    You realize so much its almost hard to argue with you (not that I
    personally would want to…HaHa). You certainly put a brand new spin on a subject that has been written about for
    decades. Great stuff, just great!

  203. Pingback: cialis paypal australia

  204. 스포츠사이트

    I do consider all the ideas you’ve offered in you

    스포츠사이트 post. They’re really convincing and can definitely work. Nonetheless, the posts are too quick for beginners. Could you please extend them a bit from subsequent time? Thanks for the post.