AAA services

AAA stands for authentication Authorization and Accounting. We all know the importance of AAA services in any network. There are numbers of ways to implement AAA services. The most commonly used are

  • Tacacs+
  • Radius
TACACS+RADIUS
Terminal Access Control Access Control Server Remote Authentication Dial-In User services.
Cisco proprietary protocolopen standard protocol
It uses TCP as transmission protocolIt uses UDP as transmission protocol
It uses TCP port number 49.It uses UDP port number 1812 for authentication and authorization and 1813 for accounting.
Authentication, Authorization and Accounting is separated in TACACS+.Authentication and Authorization is combined in RADIUS.
All the AAA packets are encrypted.Only the password are encrypted while the other information such as username, accounting information etc are not encrypted.
preferably used for ACS.used when ISE is used
It provides more granular control i.e can specify the particular command for authorization.No external authorization of commands supported.
TACACS+ offers multiprotocol supportNo multiprotocol support.
Used for device administration.used for network access

The lab below will show the implementation of Tacacs+ server and Radius Server as well.

R1#sh run
 Building configuration…
 Current configuration : 3799 bytes
 !
 ! Last configuration change at 03:18:41 UTC Fri Dec 27 2019
 !
 version 15.6
 service timestamps debug datetime msec
 service timestamps log datetime msec
 no service password-encryption
 !
 hostname R1
 !
 boot-start-marker
 boot-end-marker
 !
 !
 enable secret 5 cisco123
 !
 aaa new-model
 !
 !
 aaa group server tacacs+ tacacs-servers
  server name tacacs-server1
 !
 aaa group server radius radius-servers
  server name radius-server1
 !
 aaa authentication login default group radius-servers local
or
  aaa authentication login default group tacacs-servers local 
 !
 !
 !
 !
 !
 aaa session-id common
 ethernet lmi ce
 !
 !
 !
 mmi polling-interval 60
 no mmi auto-configure
 no mmi pvc
 mmi snmp-timeout 180
 !
 !
 !
 !
 !
 no ip icmp rate-limit unreachable
 !
 !
 !
 !
 !
 !
 no ip domain lookup
 ip domain name example.com
 ip cef
 no ipv6 cef
 !
 multilink bundle-name authenticated
 !
 !
 !
 !
 username cisco privilege 15 password 0 cisco123
 !
 interface GigabitEthernet0/0
  description tacacs-servers
  ip address 192.168.10.1 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
 !
 interface GigabitEthernet0/1
  description radius-servers
  ip address 172.16.0.1 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
 !
 interface GigabitEthernet0/2
  description host
  ip address 10.10.10.1 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
 !
 ip forward-protocol nd
 !
 !
 no ip http server
 no ip http secure-server
 !
 tacacs server tacacs-server1
  address ipv4 192.168.10.2
  key gns3
 !
 !
 radius server radius-server1
  address ipv4 172.16.0.2 auth-port 1812 acct-port 1813
  key gns3
!
 line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 line vty 0 4
 transport input ssh
 line vty 5 15
 transport input ssh
 !
 no scheduler allocate
 !
 end 

Comments

  1. g with

    I like the valuable information you provide in your articles.
    I’ll bookmark your weblog and check again here regularly.
    I am quite certain I will learn many new stuff right here!
    Good luck for the next!

  2. yakuzeed.com

    Hi there! I just wanted to ask if you ever have any problems with hackers?
    My last blog (wordpress) was hacked and I ended up losing a few
    months of hard work due to no data backup. Do you have any methods to prevent hackers?

  3. cbd oil that works 2020

    Thanks for every other magnificent article. The place else
    could anyone get that kind of info in such an ideal approach of
    writing? I’ve a presentation subsequent week, and I’m at the search for such info.

  4. cbd oil that works 2020

    Its like you read my mind! You appear to know a lot about this, like you wrote
    the book in it or something. I think that you could do with some pics to
    drive the message home a little bit, but instead of that, this is
    excellent blog. A fantastic read. I’ll certainly be back.

  5. cbd oil that works 2020

    Great post. I used to be checking constantly this
    blog and I’m impressed! Extremely helpful information specially the closing section 🙂 I deal with such information much.
    I was seeking this certain information for a very lengthy time.
    Thanks and best of luck.

  6. website hosting services

    Somebody necessarily help to make critically posts I would state.
    This is the very first time I frequented your website page and so far?
    I surprised with the research you made to create this actual put up incredible.
    Excellent job!

  7. web hosting sites

    I think this is one of the most important info for
    me. And i am glad reading your article. But should remark on few
    general things, The website style is ideal, the articles is
    really great : D. Good job, cheers

  8. website hosting

    This design is incredible! You definitely know how to keep
    a reader entertained. Between your wit and your
    videos, I was almost moved to start my own blog (well,
    almost…HaHa!) Fantastic job. I really enjoyed what you had to say,
    and more than that, how you presented it. Too cool!

  9. web hosting reviews

    I’m curious to find out what blog platform you’re using? I’m experiencing some small security problems with
    my latest website and I’d like to find something more risk-free.
    Do you have any solutions?

  10. travelocity flights

    This design is incredible! You most certainly know how to keep a reader amused.
    Between your wit and your videos, I was almost moved to start my own blog (well, almost…HaHa!) Excellent job.
    I really enjoyed what you had to say, and more than that, how you presented
    it. Too cool!

  11. last minute flights

    After going over a few of the blog articles on your web page, I honestly appreciate your way of writing a
    blog. I bookmarked it to my bookmark site list and will be checking back in the near future.

    Please visit my web site too and let me know your opinion.

  12. adreamoftrains content hosting

    I think everything wrote was very logical. But, what about this?
    suppose you were to create a awesome post title? I ain’t suggesting your information is
    not solid., however suppose you added a post title that makes people
    want more? I mean AAA services is kinda vanilla.
    You ought to peek at Yahoo’s home page and watch how they
    create article titles to get viewers interested. You might try adding a video or a pic
    or two to grab readers interested about what you’ve written. Just my opinion, it might make
    your posts a little livelier. adreamoftrains best website hosting

  13. air tickets

    Hey I know this is off topic but I was wondering if
    you knew of any widgets I could add to my blog that automatically tweet my newest
    twitter updates. I’ve been looking for a plug-in like this for quite
    some time and was hoping maybe you would have some experience with something like this.

    Please let me know if you run into anything. I truly enjoy reading your blog and I
    look forward to your new updates.

  14. web hosting reviews

    Hi there, I discovered your web site by way of Google even as searching for
    a similar matter, your website got here up, it appears good.
    I’ve bookmarked it in my google bookmarks.
    Hello there, just become aware of your weblog thru Google, and located that it’s truly
    informative. I’m going to watch out for brussels.
    I will be grateful if you continue this in future.
    Numerous other folks shall be benefited out of your writing.
    Cheers!

  15. website hosting services

    Hello this is somewhat of off topic but I
    was wondering if blogs use WYSIWYG editors or if you have to manually code with HTML.
    I’m starting a blog soon but have no coding skills so I wanted to get guidance from someone with experience.
    Any help would be greatly appreciated!

  16. cheap flights

    Greetings! I know this is kind of off topic but I was wondering if you knew where I could locate a captcha plugin for my comment form?
    I’m using the same blog platform as yours and I’m having trouble finding one?
    Thanks a lot! 3gqLYTc cheap flights

  17. cheap flights

    Definitely believe that which you said. Your favorite justification seemed
    to be on the internet the simplest thing to
    be aware of. I say to you, I certainly get irked while people think about worries that they plainly
    don’t know about. You managed to hit the nail upon the top as well as defined out the whole thing without having side-effects , people could take a signal.
    Will likely be back to get more. Thanks

  18. black mass

    Hey! I just wanted to ask if you ever have any issues with hackers?
    My last blog (wordpress) was hacked and I ended up losing several weeks of hard work due to no back up.
    Do you have any methods to prevent hackers?

  19. website host

    Hey there! I know this is kind of off topic but I was
    wondering which blog platform are you using for this site?
    I’m getting fed up of WordPress because I’ve had problems
    with hackers and I’m looking at alternatives for another
    platform. I would be great if you could point me in the direction of a good platform.

  20. SheldonGFack

    It’s perfect time to make several plans for the long run and it’s time for you to be happy.
    I’ve learn this create and when I could I want to counsel you
    some interesting things or tips. Perhaps you could write next articles concerning this short article.

    I wish to read more things approximately
    it!

    my web page :: SheldonGFack

  21. Alanrok

    [url=https://seroquelrx.com/]seroquel 400 mg cost[/url] [url=https://zoloftsrt.com/]buying zoloft online[/url] [url=https://advairdiskushfa.com/]advair generic brand name[/url] [url=https://singulairmed.com/]singulair 10mg tablets price[/url] [url=https://trazodonegen.com/]trazodone usa[/url] [url=https://bupropion2.com/]generic wellbutrin online[/url] [url=https://tadalafilstore.com/]tadalafil best price[/url] [url=https://arimidextab.com/]arimidex pharmacy[/url] [url=https://ibenicar.com/]benicar canada[/url] [url=https://levitravrd.com/]levitra cheap[/url] [url=https://baclophen.com/]buy baclofen[/url] [url=https://levitratb.com/]vardenafil canada[/url] [url=https://ataraxbuy.com/]hydroxyzine atarax[/url] [url=https://busparbuspirone.com/]buspar generic cost[/url] [url=https://hydroxychloroquinemd.com/]hydroxychloroquine tablets 10 mg[/url] [url=https://sildalis365.com/]cheapest generic sildalis[/url] [url=https://kamagramd.com/]kamagra oral jelly 100mg sildenafil citrate[/url] [url=https://abilify36.com/]order abilify[/url] [url=https://diclofenacvlt.com/]voltaren 800 mg[/url] [url=https://antabusepill.com/]how much is disulfiram 500mg[/url]

  22. Judyrok

    [url=https://buyplavix.com/]generic plavix usa[/url] [url=https://kamagrabt.com/]ajanta kamagra oral jelly[/url] [url=https://citsildenafil.com/]us online viagra prescription[/url] [url=https://levitratabs.com/]discount levitra prices[/url] [url=https://ampicillinz.com/]price of ampicillin[/url] [url=https://vardenafiltop.com/]can i buy levitra online[/url] [url=https://dapoxetinemt.com/]3131 avana[/url] [url=https://fluoxetineproz.com/]fluoxetine tablets cost[/url] [url=https://viagrapfz.com/]viagra price in mexico[/url] [url=https://citalopramn.com/]40mg citalopram[/url]

  23. Paulrok

    [url=https://ataraxmedication.com/]atarax liquid[/url] [url=https://viagranat.com/]cost of viagra australia[/url] [url=https://viagrapfz.com/]can i buy viagra over the counter uk[/url] [url=https://prazosin365.com/]prazosin 6 mg[/url] [url=https://ampicillinz.com/]ampicillin 500mg price in india[/url]

  24. Markrok

    [url=https://buspironebuspar.com/]buspar 30 mg tablet[/url] [url=https://malegrafxt.com/]malegra dxt[/url] [url=https://genuinelevitra.com/]levitra prescription online[/url] [url=https://advairmeds.com/]advair 115 21 mcg[/url]

Leave a Reply

Your email address will not be published.